newifi mini纯净版OpenWrt兼容内核固件,集成rt2860v2、mt76x2e驱动

基于原生OpenWrt Barrier Breaker 14.07,使用SDK && ImageBuilder构建,与官方14.07内核兼容,可直接安装官方源任意软件包(包括内核模块)

尝试做这个事情主要是因为PandoraBox固件没有打包某些我需要的内核模块,因为都是3.10内核,有些ko是可以忽略警告强行安装的,但少部分ko因引用内核头文件config而无法二进制兼容(例如ipset,你懂的)。

友情提醒1:此固件不适合普通小白使用,需要对OpenWRT有一定的了解,具备初级的Linux折腾能力,至少要会用vim编辑network、wireless等配置文件,因为LuCI不支持配置rt2860v2驱动的无线参数。
友情提醒2:此固件是纯净版,不因任何用户喜好集成任何功能,需要各种功能的请自己opkg安装。

感谢泄漏驱动代码的有关单位以及lintel、dq等大神的贡献:https://github.com/qdk0901/openwrt-mt7620

已知问题:
1、无法通过LuCI配置无线。这是原版ralink驱动的硬伤,请参考下面的范例配置/etc/config/wireless。
2、5G驱动使用samba时会抽,PandoraBox也有这个问题,见http://www.right.com.cn/forum/thread-149292-1-1.html#pid936103

变更历史:

20141104 r2:
1、Port到14.07正式版(14.07-rc3无法正常使用USB)。
2、添加5G驱动kmod-mt76x2e。
3、无线配置脚本使用最新PandoraBox里的脚本。
4、恢复默认的USB软件包。
5、修复2.4G与5G的LED。

20141023 r1:
1、移除mac80211及rt2800相关的驱动。
2、添加rt2860v2驱动,修复了读取ROM的一处错误。
3、添加luci-i18n-chinese
4、移除ipv6相关软件包及uci初始化时写入的ipv6相关配置。
5、移除usb相关软件包(内核兼容用时再装)。
6、修正newifi mini的交换机接口定义。
7、初始ip地址为192.168.99.1(大多人买这个当从路由)
8、初始root密码为admin。

/etc/config/wireless范例:

config wifi-device 'ra0'
	option type 'rt2860v2'
	option mode '9'
	option channel '6'
	option txpower '100'
	option ht '20+40'
	option country 'US'
	option disabled '0'

config wifi-iface
	option device 'ra0'
	option network 'lan'
	option mode 'ap'
	option ssid 'NEWIFI'
	option encryption 'psk2'
	option key 'xxxxxxxx'

config wifi-iface
	option device 'ra0'
	option network 'wwan'
	option mode 'sta'
	option ssid 'TPLINK'
	option encryption 'psk2'
	option key 'xxxxxxxx'

config wifi-device  rai0
	option type     mt7612
	option mode 	14
	option channel  auto
	option txpower 100
	option ht 20+40+80
	option country US
	
config wifi-iface
	option device   rai0
	option network	lan
	option mode     ap
	option ssid     NEWIFI_5G
	option encryption psk2
	option key xxxxxxxx

下载地址:openwrt-newifi-y1-r2-20141104

36 thoughts on “newifi mini纯净版OpenWrt兼容内核固件,集成rt2860v2、mt76x2e驱动

  1. cuihao

    原装固件没法设路由器模式,自己又不会写 network,想用 IPv6 搞不定。
    这个好用!谢谢~

    Reply
  2. Galaxy

    请问,如果想配成IPv4正常路由出去,IPv6直接把WAN桥接进来让外面的DHCPv6给LAN分配,该怎么配?

    教育网就是这种情况,2001开头的IPv6直接免费用,而IPv4要登录收费。

    Reply
    1. gmsj0001 Post author

      最安全的方法是用有线,改交换机接口定义把一个lan分到wan的vlan上。
      折腾透明桥接的话可参考这个文章:http://blog.xieyc.com/configure-ipv6-throughout-in-openwrt/
      我这边不提供技术支持,因为我们宿舍没有ipv6供实验 = =

  3. Galaxy

    Thanks.

    Just use this below:

    root@OpenWrt:~# brctl addif br-lan eth0.2
    root@OpenWrt:~# ebtables -t broute -A BROUTING -i eth0.2 -p ! ipv6 -j DROP

    Reply
  4. xykz

    你好,我在用小米路由器mini,最近也在学编译固件,有两个问题想请教一下。
    1、rt2860v2的驱动是否直接用git下载“openwrt-mt7620/package/rt2860v2”这个目录下的文件到bb的package目录就可以了?
    2、mt76x2的驱动也是如上操作吗?
    3、添加了这两个驱动之后是否还需要什么步骤引用让它们工作。

    先行谢过

    Reply
    1. gmsj0001 Post author

      1、rt2860v2可以直接checkout package/rt2860v2然后编译,不用clone整个tree。
      2、mt76x2e目前好像没人在git上放源吧。
      3、rt2860v2没什么问题,安装后直接就可以wifi detect使用。
      ps,以上仅为我设备上的经验,话说OP官方BB有支持小米mini?

    2. xykz

      op的官方git上有mt76x2e的驱动https://github.com/openwrt/mtk-wifi-gpl,恩山也有人在讨论,似乎编译出来还是有问题的,不知道博主的怎么使用的?如果方便的话,能否告知一个大概的方法呢?

      小米mini的硬件和newifi mini是一样的,固件也可以通刷,不过刷了newifi mini的固件之后wan口有问题,无法正常使用,这个原因还在查,可能是dtsi配置的原因。

    3. gmsj0001 Post author

      我用的某厂商泄漏的原版驱动。但是效果并不好,比如和usb总线冲突,而且帖子里也有人反映稳定性,以及实际速度并不比2.4g好,所以我自己现在完全不用5g了,毕竟没lintel那样深度修改的功底。
      wan口难道不是交换机接口定义的问题么。。。

    4. xykz

      看来5G的驱动暂时还是没法解决,不过op既然已经放出来了,迟早都能搞定了。
      wan口在lintel的固件里是2.2,newifi mini里是0.2,不过我手动改成了2.2也是不行,不知道什么原因

    5. gmsj0001 Post author

      不是在“接口”页改,而是要去“交换机”页看,把有电的网线挨个口插,看页面上哪个图会亮,找到实际的wan口分配到eth0.2上。newifi mini是4,原生openwrt是0。

    6. xykz

      嗯,我也试过改交换机的配置,我是保存了小米mini固件的network配置,然后刷上newifi mini的固件,对比两个network文件的交换机配置是一模一样的。我刚刚看了下,小米mini的wan口也是端口4,但是线插上去是不亮的。

      下面是我的交换机配置

      config switch
      option name ‘mt762x’
      option reset ‘1’
      option enable_vlan ‘1’

      config switch_vlan
      option device ‘mt762x’
      option vlan ‘1’
      option ports ‘0 1 2 3 5 6t’

      config switch_vlan
      option device ‘mt762x’
      option vlan ‘2’
      option ports ‘4 6t’

      ps:刚刚用官方的gpl驱动编译出来了,能看到mt76x2.ko,就是不知道能不能用,还没刷上去。。。

    1. paldier

      我小米mini刷了这个反而正常了,之前其他人和自己编译的wan口都不能用,但是无线确实一塌糊涂,还不如我自己编译的,估计是驱动问题

    1. gmsj0001 Post author

      木有,我直接用openwrt官方的ImageBuilder打包的,没动硬件设置

  5. Peter

    请问博主应该如何设置多SSID啊?谢谢!我怎么都调不出ra1出来

    Reply
  6. Kim Kong

    pppoe拨不上啊

    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ is now down
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ is disabled
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ is enabled
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ is setting up now
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: VLAN ‘eth0.3’ link is down
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ has link connectivity loss
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: VLAN ‘eth0.3’ link is up
    Mon Dec 29 16:04:06 2014 daemon.notice netifd: Interface ‘wan’ has link connectivity
    Mon Dec 29 16:04:07 2014 daemon.info pppd[5661]: Plugin rp-pppoe.so loaded.
    Mon Dec 29 16:04:07 2014 daemon.info pppd[5661]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
    Mon Dec 29 16:04:07 2014 daemon.notice pppd[5661]: pppd 2.4.7 started by root, uid 0
    Mon Dec 29 16:04:07 2014 daemon.info pppd[5661]: PPP session is 1
    Mon Dec 29 16:04:07 2014 daemon.warn pppd[5661]: Connected to 00:21:05:37:84:5d via interface eth0.3
    Mon Dec 29 16:04:07 2014 daemon.info pppd[5661]: Using interface pppoe-wan
    Mon Dec 29 16:04:07 2014 daemon.notice pppd[5661]: Connect: pppoe-wan eth0.3
    Mon Dec 29 16:04:10 2014 daemon.info pppd[5661]: Remote message: Login ok
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: PAP authentication succeeded
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: peer from calling number 00:21:05:37:84:5D authorized
    Mon Dec 29 16:04:10 2014 daemon.err pppd[5661]: IPv6 socket creation failed: Address family not supported by protocol
    Mon Dec 29 16:04:10 2014 daemon.err pppd[5661]: IPv6 socket creation failed: Address family not supported by protocol
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: local IP address 10.218.144.190
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: remote IP address 10.43.144.1
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: primary DNS address 112.4.0.55
    Mon Dec 29 16:04:10 2014 daemon.notice pppd[5661]: secondary DNS address 221.131.143.69
    Mon Dec 29 16:04:10 2014 daemon.notice netifd: Network device ‘pppoe-wan’ link is up
    Mon Dec 29 16:04:10 2014 daemon.notice netifd: Interface ‘wan’ is now up
    Mon Dec 29 16:04:10 2014 daemon.info pppd[5661]: LCP terminated by peer
    Mon Dec 29 16:04:10 2014 daemon.info pppd[5661]: Connect time 0.0 minutes.
    Mon Dec 29 16:04:10 2014 daemon.info pppd[5661]: Sent 0 bytes, received 4 bytes.
    Mon Dec 29 16:04:10 2014 daemon.notice netifd: Network device ‘pppoe-wan’ link is down
    Mon Dec 29 16:04:10 2014 daemon.notice netifd: Interface ‘wan’ has lost the connection
    Mon Dec 29 16:04:10 2014 user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)

    Reply
  7. Pingback: openWRT + shadowsocks 搭梯子 | 风吹裤裆凉

  8. AII

    请问修复LED要装什么驱动才能解决? 我刚刷了Pandora不想再折腾了。望指点

    Reply
    1. gmsj0001 Post author

      这个固件仅针对newifi mini,LED定义openwrt官方已经设定好,其他机型我没折腾过。见楼上部分评论。

  9. xyr

    我发现wifi无法关闭,option disabled ‘1’放在 wireless放在wifi-device下没作用,放在wifi-iface下会生产生成一个新的 SSID 的 wifi

    Reply
    1. gmsj0001 Post author

      这个还真没注意,大概是lintel没考虑到。要不删掉/lib/wifi下的脚本试试?(最近没用newifi,记忆中lintel的脚本是这个路径)

  10. AII

    WIFI功能Bug还很多。已知:无法显示信号信息(如功率等),调整信道和强度时经常不成功,WPA/WPA2加密功能被阉割。

    Y1版亲测
    博主下个版本完善些吧。

    Reply
  11. fastpace

    可惜了,不支持wpa wpa2加密,只有WEP。只能舍弃5G,也要保证2.4G是安全的

    Reply
  12. CacheWang

    亲测中继连接经常掉线,不得已刷回原厂固件。 没有尝试过网线直连,不排除是连接方式导致的掉线。

    Reply
  13. hackaday

    楼主,wan口的led怎么在/sys/class/leds下面没有找到,那这颗led是怎么亮的。。想要控制led晚上熄灯

    Reply
    1. hackaday

      嗯。。想了想盖住一颗led 感觉怪怪的,最后7个led都用纸盖住了- –

  14. hh9090

    博主,你好,OpenWRT/trunk,MT7628添加了MT76x2的驱动,但是系统看不到wifi的接口,并且没有配置项,这个要怎么处理才好呢? 致谢!

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Using REAL email address will help you receive reply notifications.

Current ye@r *